Supported devices and operating systems

APPLE:

For the Apple devices, World of Gems application only allows devices that are using the 9.0 version or above; 

Any version below the 9.0 will not allow you to play our application on your mobile device;

ANDROID:

For the Android devices, World of Gems only allows devices that are using the 4.4 version or above;

As well, any version below the 4.4 will not allow you to play World of Gems on your mobile device;

KINDLE:

For the Kindle devices, World of Gems only allows devices that are using the  4.4 version of  android  operating system or above; World of Gems allows devices that are 2013 year of production or higher.

Any version  of the android  operating system below 4.4 and below  2013  year of production will not give you the possibility to play World of Gems on your device.

Still need help? Contact Us Contact Us